SERP Hacker support forum - serposcope

Support forum for open-source softwares built by serphacker.com : serposcope the rank checker.

You are not logged in.

#1 2016-01-21 09:23:45

ArthanSEO
Member
Registered: 2016-01-05
Posts: 11
Website

Les taches se lancent mais n'avancent pas

Hello ! Encore moi...
Je n'avais pas retenté d'utiliser serposcope depuis quelques temps. Je viens de lancer un check manuel. La tache s'est bien lancée (il y a une dizaine de minutes) mais reste à 0% avec 0 erreurs et 0 captchas.
J'ai essayé de regarder les logs mais les seuls logs dont je dispose sont les logs commons-daemon

Last edited by ArthanSEO (2016-01-21 09:24:46)

Offline

#2 2016-01-21 09:25:46

serphacker
Administrator
Registered: 2014-06-13
Posts: 411

Re: Les taches se lancent mais n'avancent pas

Salut, dans configuration > logs tu vois quoi ?

Offline

#3 2016-01-21 09:36:48

ArthanSEO
Member
Registered: 2016-01-05
Posts: 11
Website

Re: Les taches se lancent mais n'avancent pas

Je vois ça en début de check :

[2016-01-21 10:12:58,776] [Thread-21] INFO  c.s.s.t.AbstractTask - task started for module GOOGLE of day 2016-01-21
[2016-01-21 10:12:58,789] [Thread-21] INFO  c.s.s.t.g.GoogleTask - captcha service : deathbycaptcha
[2016-01-21 10:12:59,329] [Thread-21] DEBUG c.s.s.t.g.GoogleTask - capcha service deathbycaptcha : remaining credit 0.0
[2016-01-21 10:12:59,602] [Thread-21] WARN  c.s.s.t.g.GoogleTask - captcha service deathbycaptcha : not enough credit

Je ne sais pas si le fait que je n'ai plus de crédit peut empêcher le check de se faire...
Puis première requête testée :

[2016-01-21 10:12:59,622] [google-0] INFO  c.s.s.t.g.GoogleTaskRunnable - google thread started
[2016-01-21 10:12:59,622] [google-0] INFO  c.s.s.t.g.GoogleTaskRunnable - search "<mot clef>" | try 1 | total search done : 0/42
[2016-01-21 10:12:59,624] [google-0] DEBUG c.s.s.s.g.s.GoogleScraper - GET https://www.google.fr/search?q=<mot+clef>&hl=fr via proxy:http://54.187.52.159:3128/ try 1

Premier check pas de position remontée.
Le second mot clef check semble similaire.
Le troisième check est un peu différent :

[2016-01-21 10:13:00,745] [google-2] WARN  c.s.s.t.g.GoogleTaskRunnable - scrap failed for <mot clef> because of ERROR_NETWORK

C'est une erreur de proxy ?
Et un peu après j'ai :

[2016-01-21 10:13:02,644] [google-0] WARN  c.s.s.t.g.GoogleTaskRunnable - scrap failed for <mot clef> because of ERROR_CAPTCHA_NO_SOLVER

Le truc c'est que même les check qui n'ont pas levé de captcha ne s'affichent pas.

Offline

#4 2016-01-21 09:42:57

serphacker
Administrator
Registered: 2014-06-13
Posts: 411

Re: Les taches se lancent mais n'avancent pas

[2016-01-21 10:13:00,745] [google-2] WARN  c.s.s.t.g.GoogleTaskRunnable - scrap failed for <mot clef> because of ERROR_NETWORK

Erreur proxy ou proxy blacklisté.

[2016-01-21 10:13:02,644] [google-0] WARN  c.s.s.t.g.GoogleTaskRunnable - scrap failed for <mot clef> because of ERROR_CAPTCHA_NO_SOLVER

Google a renvoyé un captcha mais pas de solveur/service configuré, impossible de vérifier le mot clef.

La tache reste en exécution tant qu'il y aura des proxies à utiliser, ils sont éjectés lorsqu'ils générent trop de ERROR_NETWORK et la tache fini par s'arreter (avec un status DONE_WITH_ERROR).

Offline

#5 2016-01-21 10:04:21

ArthanSEO
Member
Registered: 2016-01-05
Posts: 11
Website

Re: Les taches se lancent mais n'avancent pas

Ok, je comprends. Ce qui m'étonne c'est que sur l'interface, dans la liste des taches, la barre d'avancement est restée à 0% et les erreurs et les captchas sont restés à 0 alors que le check a avancé et a remonté des erreurs et des problèmes de captcha.
C'est moi qui interprète mal l'interface ?

Offline

#6 2016-01-21 10:20:01

serphacker
Administrator
Registered: 2014-06-13
Posts: 411

Re: Les taches se lancent mais n'avancent pas

0% car 0% de mot-clés de vérifié avec succès.
0 captcha car 0 captcha cassé: aucun service pour gérer les captchas configurés. Cependant je vais afficher le nombre de captchas reçu et non le nombre de captcha cassé dans la prochaine version car ça prête à confusion.
0 erreur car il y a un bug et le logiciel ne met pas à jour en temps réel le nombre d'erreur rencontré mais seulement à la fin du run. https://github.com/serphacker/serposcope/issues/54

En gros ta tache avance, mais aucun mot-clé n'a pu être checké à cause de proxy incorrect ou renvoie de captcha et pas de service pour les captchas. Voir la FAQ & la doc pour optimiser.

Offline

#7 2016-01-21 10:26:23

ArthanSEO
Member
Registered: 2016-01-05
Posts: 11
Website

Re: Les taches se lancent mais n'avancent pas

Je vois ! Merci de l'info. Problème d'interprétation de ma part donc.
Je sais pas si je dois proposer ça sur le github mais de mon point de vue la barre d'avancement devrait évoluer même avec les checks en erreur.

Offline

#8 2016-01-21 10:27:09

serphacker
Administrator
Registered: 2014-06-13
Posts: 411

Re: Les taches se lancent mais n'avancent pas

Offline

Board footer