SERP Hacker support forum - serposcope

Support forum for open-source softwares built by serphacker.com : serposcope the rank checker.

You are not logged in.

#1 2015-08-22 08:03:37

jlweb
Member
Registered: 2015-08-22
Posts: 9

ERROR ABNORMAL TERMINATION

Bonjour,
J'ai un problème qui semble récurrent.
Je viens d'installer Serposcope v1.0.7 sur mon serveur dédié.

Maximum execution time est à 0 comme recommandé.
Lorsque je lance un crawl manuellement mon script s'arrête tout le temps au bout de 430 secondes environ.

Dans les logs j'ai cela :
ERROR ABNORMAL TERMINATION : process may have been killed or reached max execution time

Côté serveur j'ai cette erreur :
[warn] [client 85.171.46.231] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server, referer: http://www.digiserp.com/view.php?idGroup=2
[Sat Aug 22 09:48:38 2015] [error] [client 85.171.46.231] Premature end of script headers: cron.php, referer: http://www.digiserp.com/view.php?idGroup=2

D'où peut provenir ce problème ?

Merci d'avance

Offline

#2 2015-08-24 19:03:15

serphacker
Administrator
Registered: 2014-06-13
Posts: 411

Re: ERROR ABNORMAL TERMINATION

Cela est du à une erreur de configuration du serveur qui empêche l'exécution du script pendant + de 430 secondes. Il faut regarder au niveau de la configuration php ou cgi, il doit y avoir une directive similaire à max_execution_time qui bloque l'exécution du script.

Offline

#3 2015-08-25 11:36:39

jlweb
Member
Registered: 2015-08-22
Posts: 9

Re: ERROR ABNORMAL TERMINATION

Voici mes logs.

Run done in 00:00:03 with error (PID: 3384 started: 2015-08-25 13:33:03)
-----
[25/08/2015 01:33:03][Cron] Starting cron via "cgi-fcgi"
[25/08/2015 01:33:03][Cron] DEBUG: display total unit 2
[25/08/2015 01:33:03][Cron] ERROR: DeathByCaptcha balance is to low
[25/08/2015 01:33:03][Cron] Clearing the cache (force=1)...
[25/08/2015 01:33:03][Cron] Cache clear
[25/08/2015 01:33:03][Cron] Checking group[1] Monsite.fr with module Google
[25/08/2015 01:33:03][Google] Using current proxy DIRECT
[25/08/2015 01:33:03][Google] Checking Mon mot cle on www.google.com
[25/08/2015 01:33:03][Curl] DEBUG: GET http://www.google.com/preferences via DIRECT (mem: 0.75M/128M)
[25/08/2015 01:33:04][Curl] DEBUG: GOT status=200 cache=MISS age=0 (mem: 1M/128M)
[25/08/2015 01:33:04][Google] DEBUG: local search not used
[25/08/2015 01:33:04][Curl] DEBUG: GET https://www.google.com/search?q=mon+motcle via DIRECT (mem: 1M/128M)
[25/08/2015 01:33:04][Curl] DEBUG: GOT status=200 cache=MISS age=0 (mem: 1.25M/128M)
[25/08/2015 01:33:05][Curl] DEBUG: GET https://www.google.com/search?q=mon+motcle&start=10 via DIRECT (mem: 1.25M/128M)
[25/08/2015 01:33:05][Curl] DEBUG: GOT status=200 cache=MISS age=0 (mem: 1.5M/128M)
[25/08/2015 01:33:05][Google] Rank[16] [www.monsite.fr] http://www.monsite.fr/
[25/08/2015 01:33:05][Google] Using current proxy DIRECT
[25/08/2015 01:33:05][Google] Checking monsite on www.google.com
[25/08/2015 01:33:05][Curl] DEBUG: GET http://www.google.com/preferences via DIRECT (mem: 1.5M/128M)
[25/08/2015 01:33:05][Curl] DEBUG: GOT status=200 cache=MISS age=0 (mem: 1.5M/128M)
[25/08/2015 01:33:05][Google] DEBUG: local search not used
[25/08/2015 01:33:05][Curl] DEBUG: GET https://www.google.com/search?q=monsite via DIRECT (mem: 1.5M/128M)
[25/08/2015 01:33:06][Curl] DEBUG: GOT status=200 cache=MISS age=0 (mem: 1.5M/128M)
[25/08/2015 01:33:06][Google] Rank[1] [www.monsite.fr] http://www.monsite.fr/
[25/08/2015 01:33:06][Cron] Checking done for group[1] monsite.fr
[25/08/2015 01:33:06][Cron] All groups done
[25/08/2015 01:33:06][Cron] Clearing the cache (force=1)...
[25/08/2015 01:33:06][Cron] Cache clear
-----
Process terminated, end of log

D'après les log tout semble s'être bien déroulé et pourtant c'est en erreur :-(

Offline

Board footer