SERP Hacker support forum - serposcope

Support forum for open-source softwares built by : serposcope the rank checker.

You are not logged in.

#1 2016-02-26 16:18:45

Registered: 2016-02-26
Posts: 2

Can't add website


yesterday I installed Serposcope 2.3.0 on a MacBook Pro with OS X 10.11.2
Java Version ist 1.8.0_73

I set up a group and then set up a search.
Before running the search I tried to add a website.
Didn’t work. Error: Invalid pattern
Neither „exact domain“ nore „domain with subdomain“ more „regex“ worked.

I figured that maybe I have to run the search first before adding a website.
So I started the search. It ran all night and morning.

When the search was finished I could see the search results.
But adding a website is still impossible.
I tired for "exact domain"
Tried for „domain with subdomain“
Always get the same error: Invalid pattern

Can you help?


#2 2016-02-26 16:24:03

Registered: 2014-06-13
Posts: 411

Re: Can't add website

That's a really strange error. What is your browser ? Did you try with another browser ? We may have a html/javascript bug.

If it doesn't works with another browser, can you make a screen of the "New website" form before you click on save (with filed inputs).

Also, if you did run a search, try to click on the search, you should have a SERP view with a list of ranked website, click on the star near a random url, and tell me if it add the url as a website.


#3 2016-03-01 20:09:31

Registered: 2016-02-26
Posts: 2

Re: Can't add website

Thanks for your reply,

adding a website from the SERP-list via the star icon worked fine. Once the first website was added it was also possible to enter new websites via the form. Safari 9.0.2 and Firefox 44.0.2 work perfectly now.

Cheers & Thx


#4 2017-11-28 14:46:04

Registered: 2016-05-04
Posts: 2

Re: Can't add website

I have also run into this problem.

I am using Version 2.8.0

I have tried adding using all three methods Exact Domin, SubDomain and Regex all of which result in the message "invalid pattern"

I am able to add an Exact Domain using the method you describe, I create a search then click the "add website" icon to the left of the relevant result item.

However this method does not work with the regex option, the add website only passes through the domain, then I get invalid pattern.

I have tried using the most recent versions of Mozilla Firefox and Chromium.

I am trying to add a regex to track youtube video serp.

I even configured serposcope to use mysql and tried to directly enter a regex as follows:

INSERT INTO `serposcope`.`GOOGLE_TARGET` (`id`, `group_id`, `name`, `pattern_type`, `pattern`) VALUES ('4', '1', 'FreeCAD Expoded Assembly', '2', ' https?://www\\.youtube\\.com/watch\\?v=jh5utko69Rc');

So even though I can see the url in the search, it does not register as a hit.

I love this program, and reaaly want to use it track my video serps, any ideas?

I don't mind digging to solve the problem for myself I just need a hint as tio where to look next, I  am currently trying to get SQL debug logs.

Last edited by thedocoffice (2017-11-28 14:53:41)


Board footer